[#3582133]Compatibility fix for GTK < 2.21.
authorAndriy Grytsenko <andrej@rep.kiev.ua>
Wed, 31 Oct 2012 13:22:51 +0000 (15:22 +0200)
committerAndriy Grytsenko <andrej@rep.kiev.ua>
Wed, 31 Oct 2012 13:22:51 +0000 (15:22 +0200)
GTK < 2.21 has no GDK_KEY_xxx but GDK_xxx.
Commit 08c4ba2700e5b7a400bc940b973010ed6fd2e84d misses to add compatibility defines.

src/gseal-gtk-compat.h

index 85803fa..6c1dbb7 100644 (file)
@@ -41,6 +41,9 @@ G_BEGIN_DECLS
 #define GDK_KEY_Down                            GDK_Down
 #define GDK_KEY_space                           GDK_space
 #define GDK_KEY_F2                              GDK_F2
+#define GDK_KEY_Return                          GDK_Return
+#define GDK_KEY_ISO_Enter                       GDK_ISO_Enter
+#define GDK_KEY_KP_Enter                        GDK_KP_Enter
 #endif
 
 #if !GTK_CHECK_VERSION (2, 20, 0)