[#3600913]Remove obsolete automake macro AM_PROG_CC_STDC.
[lxde/pcmanfm.git] / autogen.sh
1 #! /bin/sh
2 AC_VERSION=
3
4 AUTOMAKE=${AUTOMAKE:-automake}
5 AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
7 # FIXME: we need a better way for version check later.
8 if [ "$AM_INSTALLED_VERSION" != "1.10" \
9 -a "$AM_INSTALLED_VERSION" != "1.11" \
10 -a "$AM_INSTALLED_VERSION" != "1.12" ];then
11 echo
12 echo "You must have automake > 1.10 or 1.11 installed."
13 echo "Install the appropriate package for your distribution,"
14 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
15 exit 1
16 fi
17
18 set -x
19
20 if [ "x${ACLOCAL_DIR}" != "x" ]; then
21 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
22 fi
23
24 ${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
25 ${AUTOHEADER:-autoheader$AC_VERSION} --force
26 AUTOMAKE=$AUTOMAKE intltoolize -c --automake --force
27 $AUTOMAKE --add-missing --copy --include-deps
28 ${AUTOCONF:-autoconf$AC_VERSION}
29
30 rm -rf autom4te.cache