[#3600913]Remove obsolete automake macro AM_PROG_CC_STDC.
[lxde/pcmanfm.git] / autogen.sh
CommitLineData
b6e3c554
HJYP
1#! /bin/sh
2AC_VERSION=
3
4AUTOMAKE=${AUTOMAKE:-automake}
5AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
c44d6d38 7# FIXME: we need a better way for version check later.
b6e3c554 8if [ "$AM_INSTALLED_VERSION" != "1.10" \
c44d6d38
HJYP
9 -a "$AM_INSTALLED_VERSION" != "1.11" \
10 -a "$AM_INSTALLED_VERSION" != "1.12" ];then
b6e3c554 11 echo
c44d6d38 12 echo "You must have automake > 1.10 or 1.11 installed."
b6e3c554
HJYP
13 echo "Install the appropriate package for your distribution,"
14 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
15 exit 1
16fi
17
18set -x
19
20if [ "x${ACLOCAL_DIR}" != "x" ]; then
21 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
22fi
23
24${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
25${AUTOHEADER:-autoheader$AC_VERSION} --force
b6e3c554
HJYP
26AUTOMAKE=$AUTOMAKE intltoolize -c --automake --force
27$AUTOMAKE --add-missing --copy --include-deps
28${AUTOCONF:-autoconf$AC_VERSION}
29
30rm -rf autom4te.cache