Fixes Qt4 build
authorLuís Pereira <luis.artur.pereira@gmail.com>
Fri, 5 Jan 2018 12:12:01 +0000 (12:12 +0000)
committerAlf Gaida <agaida@siduction.org>
Sat, 6 Jan 2018 00:10:05 +0000 (01:10 +0100)
Translation build was failing. We change the Qt default version in
LXQtTranslateTs but did not updated it's use accordingly.

CMakeLists.txt
src/CMakeLists.txt

index 022fa11..a6b0e8f 100644 (file)
@@ -14,11 +14,14 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
 set(CMAKE_POSITION_INDEPENDENT_CODE ON)
 set(CMAKE_AUTOMOC ON)
 
+
 if(USE_QT4)
+  set(USE_QT5 FALSE)
   find_package(Qt4 REQUIRED QtCore QtGui) # Qt
   include(${QT_USE_FILE})
   message(STATUS "Building with Qt${QTVERSION}")
 else()
+  set(USE_QT5 TRUE)
   cmake_minimum_required(VERSION 3.0.2 FATAL_ERROR)
   find_package(Qt5Widgets REQUIRED)
   find_package(Qt5X11Extras REQUIRED)
index cd0b1f5..88196b4 100644 (file)
@@ -60,8 +60,8 @@ add_custom_command(
 # add translation for obconf-qt
 option (UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
 lxqt_translate_ts(QM_FILES
-  USE_QT4
-    ${USE_QT4}
+  USE_QT5
+    ${USE_QT5}
   UPDATE_TRANSLATIONS
     ${UPDATE_TRANSLATIONS}
   SOURCES