lxpanel.pc should not contain libfm-gtk, only libfm - gtk headers aren't required...