Migrate loadable plugin "batt" to new plugins API.