Use keybinder variant appropriate to used GTK+ version (2.0/3.0).
authorAndriy Grytsenko <andrej@rep.kiev.ua>
Sat, 6 Dec 2014 21:05:26 +0000 (23:05 +0200)
committerAndriy Grytsenko <andrej@rep.kiev.ua>
Sat, 6 Dec 2014 21:05:26 +0000 (23:05 +0200)
configure.ac

index ed4ef12..1885c48 100644 (file)
@@ -35,8 +35,10 @@ esac],[])
 
 if test "x$enable_gtk3" = "xyes" ; then
   pkg_modules="$pkg_modules gtk+-3.0 libfm-gtk3 >= 1.2.0 libwnck-3.0"
+  keybinder_module=keybinder-3.0
 else
   pkg_modules="$pkg_modules gtk+-2.0 >= 2.18.0 libfm-gtk >= 1.2.0 libwnck-1.0"
+  keybinder_module=keybinder
 fi
 
 pkg_modules="$pkg_modules \
@@ -47,7 +49,7 @@ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
 AC_SUBST(PACKAGE_CFLAGS)
 AC_SUBST(PACKAGE_LIBS)
 
-PKG_CHECK_MODULES(KEYBINDER, [keybinder])
+PKG_CHECK_MODULES(KEYBINDER, [$keybinder_module])
 AC_SUBST(KEYBINDER_CFLAGS)
 AC_SUBST(KEYBINDER_LIBS)