autogen.sh, configure.ac: support automake 1.12, fix warnings
authorHenry Gebhardt <hsggebhardt@googlemail.com>
Thu, 19 Jul 2012 21:13:54 +0000 (23:13 +0200)
committerHenry Gebhardt <hsggebhardt@googlemail.com>
Thu, 19 Jul 2012 21:13:54 +0000 (23:13 +0200)
.gitignore
autogen.sh
configure.ac

index 8a47fc2..0ac0e80 100644 (file)
@@ -1,5 +1,6 @@
 Makefile.in
 aclocal.m4
+ar-lib
 autom4te.cache/
 compile
 config.h.in
index 5d68ab5..c993cf3 100755 (executable)
@@ -5,9 +5,10 @@ AUTOMAKE=${AUTOMAKE:-automake}
 AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
 
 if [ "$AM_INSTALLED_VERSION" != "1.10" \
-    -a "$AM_INSTALLED_VERSION" != "1.11" ];then
+    -a "$AM_INSTALLED_VERSION" != "1.11" \
+    -a "$AM_INSTALLED_VERSION" != "1.12" ];then
        echo
-       echo "You must have automake > 1.10 or 1.11 installed to compile lxpanel."
+       echo "You must have automake 1.10, 1.11, or 1.12 installed to compile lxpanel."
        echo "Install the appropriate package for your distribution,"
        echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
        exit 1
index 0856c67..ad3ec08 100644 (file)
@@ -1,6 +1,6 @@
 AC_PREREQ(2.53)
 AC_INIT(lxpanel, 0.5.10, http://lxde.org/)
-AM_INIT_AUTOMAKE([1.11 -Wall -Werror foreign])
+AM_INIT_AUTOMAKE([-Wall foreign])
 AC_CONFIG_HEADER([config.h])
 
 # Support silent build rules. Disable by either passing --disable-silent-rules
@@ -16,6 +16,7 @@ AC_PROG_INSTALL
 AC_PROG_LN_S
 AC_PROG_INTLTOOL(, [no-xml])
 AM_PROG_CC_C_O
+AM_PROG_AR
 
 #Initialize libtool
 LT_PREREQ([2.2])