Improve default config.
authorHong Jen Yee (PCMan) <pcman.tw@gmail.com>
Sun, 26 Nov 2006 07:08:30 +0000 (07:08 +0000)
committerHong Jen Yee (PCMan) <pcman.tw@gmail.com>
Sun, 26 Nov 2006 07:08:30 +0000 (07:08 +0000)
Add missing build-dep to debian/control.

data/Makefile.am
data/default.in
debian/control

index 30f41f2..355020d 100644 (file)
@@ -21,6 +21,7 @@ lxpanel_images_DATA = \
        images/gnome-graphics.png \
        images/gnome-joystick.png \
        images/gnome-multimedia.png \
+       images/gnome-logout.png \
        images/gnome-netstatus-0-24.png \
        images/gnome-netstatus-25-49.png \
        images/gnome-netstatus-50-74.png \
index d7550ec..d440419 100644 (file)
@@ -2,7 +2,6 @@
 ## lxpanel configuration file         ##
 ########################################
 
-
 # DESCRIPTION
 # Configuration file consists of mandatory 'Global' block that MUST come first,
 # and optionally one or more 'Plugin' block.
@@ -67,8 +66,6 @@
 #     # Alpha = 127
 # }
 
-
-
 # 'Plugin' block specifies a plugin to load. It has same syntax for both
 # builtin and external plugins.
 
 # space       - just seize space
 # pager       - thumbnailed view of the desktop
 # tray        - tray for XEMBED icons (aka docklets)
+# volume      - volume control
+# cpu         - cpu usage monitor
+# netstatus   - net status (ported from gnome-panel)
 
 # expand - specifies if plugin can accomodate extra space or not [optional]
 # padding - extra paddin around plugin  [optional]
 # config {} - block of plugin's private configuration. 
 #             This part is plugin  dependant
 
-
-#  
-# Plugin {
-#     type = wincmd
-#     config {
-#         image = ~/.lxpanel/images/Desktop2.png
-#     }
-# }
-
-
 Global {
-
     edge = bottom
     allign = left
     margin = 0
@@ -108,11 +97,8 @@ Global {
     width = 100
     heighttype = pixel
     height = 26
-    roundcorners = false 
 }
 
-
-
 Plugin {
     type = space
     config {
@@ -120,7 +106,6 @@ Plugin {
     }
 }
 
-
 Plugin {
     type = menu
     config {
@@ -136,56 +121,52 @@ Plugin {
             image = @prefix@/share/lxpanel/images/gnome-setting.svg
             command = configure
         }
+        separator {
+        }
+        item {
+            image = gnome-logout
+            command = logout
+        }
     }
 }
 
-
 Plugin {
     type = space
     config {
-            size = 5
+            size = 4
     }
 }
 
-
 Plugin {
     type = launchbar
     config {
         button {
             id = pcmanfm.desktop
         }
-
         button {
             id = gnome-terminal.desktop
         }
-
         button {
             id = firefox.desktop
         }
     }
-
 }
 
 Plugin {
     type = space
     config {
-            size = 8
+            size = 4
     }
 }
 
-
 Plugin {
     type = wincmd
-    config {
-        image = @prefix@/share/lxpanel/images/gnome-fs-desktop.svg
-    }
 }
 
-
 Plugin {
     type = space
     config {
-            size = 7
+            size = 4
     }
 }
 
@@ -216,18 +197,16 @@ Plugin {
             AppName = emacs
             ClassName = Emacs
         }
-
     }
 }
 
 Plugin {
     type = space
     config {
-        size = 5
+        size = 4
     }
 }
 
-
 Plugin {
     type = taskbar
     expand = true
@@ -249,15 +228,19 @@ Plugin {
 
 # Net status plug-in
 # %i in configtool is only a place holder, and will be replace by the value of iface.
-#
-# Plugin {
-#     type = netstatus
-#     config {
-#         iface = eth0
-#         configtool = network-admin --configure %i
-#     }
-# }
 
+Plugin {
+    type = netstatus
+    config {
+        iface = eth0
+        configtool = network-admin --configure %i
+    }
+}
+
+# CPU monitor
+Plugin {
+    type = cpu
+}
 
 Plugin {
     type = tray
@@ -272,4 +255,3 @@ Plugin {
         Action = xmessage Please define some command &
     }
 }
-
index 763e29e..a358e57 100644 (file)
@@ -2,7 +2,7 @@ Source: lxpanel
 Section: x11
 Priority: extra
 Maintainer: PCMan <pcman.tw@gmail.com>
-Build-Depends: debhelper (>= 5), autotools-dev, libgtk2.0-dev (>=2.6), libglib2.0-dev(>=2.10), libxmu-dev
+Build-Depends: debhelper (>= 5), autotools-dev, libgtk2.0-dev (>=2.6), libglib2.0-dev(>=2.10), libxmu-dev libxpm-dev
 Standards-Version: 3.7.2
 
 Package: lxpanel