Use automake 1.10 officially.
[lxde/lxpanel.git] / autogen.sh
CommitLineData
a52c2257 1#! /bin/sh
40cbe5f1 2AM_VERSION=-1.10
a52c2257
HJYP
3AC_VERSION=
4
5set -x
6
7if [ "x${ACLOCAL_DIR}" != "x" ]; then
8 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
9fi
10
208952a8 11${ACLOCAL:-aclocal$AC_VERSION} ${ACLOCAL_ARG}
a52c2257 12${AUTOHEADER:-autoheader$AC_VERSION}
faa2693d 13AUTOMAKE=${AUTOMAKE:-automake$AM_VERSION} libtoolize -c --automake --force
a52c2257
HJYP
14AUTOMAKE=${AUTOMAKE:-automake$AM_VERSION} intltoolize -c --automake --force
15${AUTOMAKE:-automake$AM_VERSION} --add-missing --copy --include-deps
16${AUTOCONF:-autoconf$AC_VERSION}
17
18# mkinstalldirs was not correctly installed in some cases.
bc7ec4ff 19cp -f /usr/share/${AUTOMAKE:-automake$AM_VERSION}/mkinstalldirs .
a52c2257
HJYP
20
21rm -rf autom4te.cache