src/panel.c: cleanup panel_draw_label_text()
[lxde/lxpanel.git] / autogen.sh
CommitLineData
a52c2257 1#! /bin/sh
a52c2257
HJYP
2AC_VERSION=
3
2e498977 4AUTOMAKE=${AUTOMAKE:-automake}
d2ca258a 5AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
2e498977
JH
6
7if [ "$AM_INSTALLED_VERSION" != "1.10" \
b37d0e40
HG
8 -a "$AM_INSTALLED_VERSION" != "1.11" \
9 -a "$AM_INSTALLED_VERSION" != "1.12" ];then
2e498977 10 echo
b37d0e40 11 echo "You must have automake 1.10, 1.11, or 1.12 installed to compile lxpanel."
2e498977
JH
12 echo "Install the appropriate package for your distribution,"
13 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
14 exit 1
15fi
16
a52c2257
HJYP
17set -x
18
19if [ "x${ACLOCAL_DIR}" != "x" ]; then
20 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
21fi
22
e7a42ecf 23${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
24${AUTOHEADER:-autoheader$AC_VERSION} --force
9e140765
JH
25AUTOMAKE=$AUTOMAKE libtoolize -c --automake --force
26AUTOMAKE=$AUTOMAKE intltoolize -c --automake --force
2e498977 27$AUTOMAKE --add-missing --copy --include-deps
a52c2257
HJYP
28${AUTOCONF:-autoconf$AC_VERSION}
29
a52c2257 30rm -rf autom4te.cache