Support automake newer than 1.11.
authorAndriy Grytsenko <andrej@rep.kiev.ua>
Tue, 9 Sep 2014 23:03:18 +0000 (02:03 +0300)
committerAndriy Grytsenko <andrej@rep.kiev.ua>
Tue, 9 Sep 2014 23:03:18 +0000 (02:03 +0300)
autogen.sh

index 8224641..d6d1dc7 100755 (executable)
@@ -4,16 +4,19 @@ AC_VERSION=
 AUTOMAKE=${AUTOMAKE:-automake}
 AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
 
-if [ "$AM_INSTALLED_VERSION" != "1.10" \
-    -a "$AM_INSTALLED_VERSION" != "1.11" ];then
+case "$AM_INSTALLED_VERSION" in
+    1.1[0-9])
+       ;;
+    *)
        echo
-       echo "You must have automake > 1.10 or 1.11 installed to compile lxde-common."
+       echo "You must have automake 1.10 or newer installed to build this."
        echo "Install the appropriate package for your distribution,"
        echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
        exit 1
-fi
+       ;;
+esac
 
-set -x
+set -ex
 
 if [ "x${ACLOCAL_DIR}" != "x" ]; then
   ACLOCAL_ARG=-I ${ACLOCAL_DIR}