Release 0.5.1.
[lxde/lxde-icon-theme.git] / autogen.sh
1 #! /bin/sh
2 AC_VERSION=
3
4 AUTOMAKE=${AUTOMAKE:-automake}
5 AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
7 case "$AM_INSTALLED_VERSION" in
8 1.1[0-9])
9 ;;
10 *)
11 echo
12 echo "You must have automake 1.10 or newer installed to build this."
13 echo "Install the appropriate package for your distribution,"
14 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
15 exit 1
16 ;;
17 esac
18
19 set -ex
20
21 if [ "x${ACLOCAL_DIR}" != "x" ]; then
22 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
23 fi
24
25 ${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
26 $AUTOMAKE --add-missing --copy --include-deps
27 ${AUTOCONF:-autoconf$AC_VERSION}
28
29 rm -rf autom4te.cache