Update autogen.sh to support automake > 1.11
[lxde/lxde-common.git] / autogen.sh
1 #! /bin/sh
2 AC_VERSION=
3
4 AUTOMAKE=${AUTOMAKE:-automake}
5 AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
7 # FIXME: we need a better way for version check later.
8 case "$AM_INSTALLED_VERSION" in
9 1.1[0-9])
10 ;;
11 *)
12 echo
13 echo "You must have automake >= 1.10 installed to build lxde-common."
14 echo "Install the appropriate package for your distribution,"
15 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
16 exit 1
17 esac
18
19 set -x
20
21 if [ "x${ACLOCAL_DIR}" != "x" ]; then
22 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
23 fi
24
25 ${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
26 $AUTOMAKE --add-missing --copy --include-deps
27 ${AUTOCONF:-autoconf$AC_VERSION}
28
29 rm -rf autom4te.cache