Commit from LXDE Pootle server by user kizito.: 14 of 14 strings translated (0 need...
[lxde/lxde-common.git] / autogen.sh
CommitLineData
2c453b37 1#! /bin/sh
2c453b37
HJYP
2AC_VERSION=
3
edfe89a1 4AUTOMAKE=${AUTOMAKE:-automake}
5AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
6c619a21
AG
7# FIXME: we need a better way for version check later.
8case "$AM_INSTALLED_VERSION" in
9 1.1[0-9])
10 ;;
11 *)
edfe89a1 12 echo
6c619a21 13 echo "You must have automake >= 1.10 installed to build lxde-common."
edfe89a1 14 echo "Install the appropriate package for your distribution,"
15 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
16 exit 1
6c619a21 17esac
edfe89a1 18
2c453b37
HJYP
19set -x
20
21if [ "x${ACLOCAL_DIR}" != "x" ]; then
22 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
23fi
24
25${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
3f716ca4 26AUTOMAKE=$AUTOMAKE intltoolize -c --automake --force
edfe89a1 27$AUTOMAKE --add-missing --copy --include-deps
2c453b37
HJYP
28${AUTOCONF:-autoconf$AC_VERSION}
29
2c453b37 30rm -rf autom4te.cache