Update Copyright years in the About dialog.
[lxde/lxappearance.git] / autogen.sh
CommitLineData
0cd84ed6
HJYP
1#! /bin/sh
2AC_VERSION=
3
4AUTOMAKE=${AUTOMAKE:-automake}
5AM_INSTALLED_VERSION=$($AUTOMAKE --version | sed -e '2,$ d' -e 's/.* \([0-9]*\.[0-9]*\).*/\1/')
6
6a425f6b
JL
7# FIXME: we need a better way for version check later.
8case "$AM_INSTALLED_VERSION" in
9 1.1[1-9])
10 ;;
11 *)
0cd84ed6 12 echo
6a425f6b 13 echo "You must have automake >= 1.11 installed."
0cd84ed6
HJYP
14 echo "Install the appropriate package for your distribution,"
15 echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
16 exit 1
6a425f6b
JL
17 ;;
18esac
0cd84ed6 19
0cd84ed6
HJYP
20
21if [ "x${ACLOCAL_DIR}" != "x" ]; then
6a425f6b 22 ACLOCAL_ARG=-I ${ACLOCAL_DIR}
0cd84ed6
HJYP
23fi
24
6a425f6b
JL
25set -x
26
0cd84ed6
HJYP
27${ACLOCAL:-aclocal$AM_VERSION} ${ACLOCAL_ARG}
28${AUTOHEADER:-autoheader$AC_VERSION} --force
0cd84ed6
HJYP
29AUTOMAKE=$AUTOMAKE intltoolize -c --automake --force
30$AUTOMAKE --add-missing --copy --include-deps
31${AUTOCONF:-autoconf$AC_VERSION}
32
33rm -rf autom4te.cache