Adds missing libqtxdg dependency
authorLuís Pereira <luis.artur.pereira@gmail.com>
Sat, 31 May 2014 18:20:31 +0000 (11:20 -0700)
committerLuís Pereira <luis.artur.pereira@gmail.com>
Sat, 31 May 2014 18:20:31 +0000 (11:20 -0700)
Fixes an FTBFS.
Projects that included libqtxd headers would fail.

Signed-off-by: Luís Pereira <luis.artur.pereira@gmail.com>
cmake/lxqt_use.cmake.in

index 6180d02..b9f4d26 100644 (file)
@@ -75,6 +75,9 @@ SET_SOURCE_FILES_PROPERTIES(LXQT_LIBRARIES PROPERTIES OBJECT_DEPENDS lxqt${LXQT_
 if (LXQT_QT_VERSION EQUAL "4")
     find_package(Qt4 REQUIRED QUIET)
     include(${QT_USE_FILE})
+
+    find_package(qtxdg REQUIRED)
+    include(${QTXDG_USE_FILE})
 elseif(LXQT_QT_VERSION EQUAL "5")
     find_package(Qt5Widgets REQUIRED QUIET)
     find_package(Qt5DBus REQUIRED QUIET)