Adds a CMake minimum version requirement to the -config.cmake
authorLuís Pereira <luis.artur.pereira@gmail.com>
Wed, 16 Nov 2016 19:13:54 +0000 (19:13 +0000)
committerLuís Pereira <luis.artur.pereira@gmail.com>
Wed, 30 Nov 2016 18:24:58 +0000 (18:24 +0000)
3.0.2 is our minimum.

cmake/lxqt-config.cmake.in

index 887af96..227d789 100644 (file)
@@ -2,6 +2,10 @@
 
 @PACKAGE_INIT@
 
+if (CMAKE_VERSION VERSION_LESS 3.0.2)
+    message(FATAL_ERROR \"@PROJECT_NAME@ requires at least CMake version 3.0.2\")
+endif()
+
 include(CMakeFindDependencyMacro)
 
 find_dependency(Qt5Widgets @QT_MINIMUM_VERSION@)