Make liblxqt depend on lxqt-build-tools
authorLuís Pereira <luis.artur.pereira@gmail.com>
Fri, 14 Oct 2016 15:33:57 +0000 (16:33 +0100)
committerLuís Pereira <luis.artur.pereira@gmail.com>
Fri, 14 Oct 2016 15:33:57 +0000 (16:33 +0100)
This way when using the liblxqt package we are implicitly using
lxqt-build-tools.
Proposed by palinek at
https://github.com/lxde/liblxqt/pull/109#issuecomment-252158163

cmake/lxqt-config.cmake.in

index 3d6f0c8..9c1a6e5 100644 (file)
@@ -57,6 +57,7 @@ find_dependency(Qt5X11Extras @QT_MINIMUM_VERSION@)
 find_dependency(Qt5LinguistTools @QT_MINIMUM_VERSION@)
 find_dependency(Qt5Xdg @QTXDG_MINIMUM_VERSION@)
 find_dependency(KF5WindowSystem)
+find_dependency(lxqt-build-tools @LXQTBT_MINIMUM_VERSION@)
 
 if (CMAKE_VERSION VERSION_GREATER 2.8.12)
     cmake_policy(SET CMP0024 OLD)