CMakeLists.txt maintenaince
authorLuís Pereira <luis.artur.pereira@gmail.com>
Fri, 7 Nov 2014 15:50:02 +0000 (07:50 -0800)
committerLuís Pereira <luis.artur.pereira@gmail.com>
Fri, 7 Nov 2014 15:50:02 +0000 (07:50 -0800)
qt5_use_modules() is obsolete. Updating also the cmake_minimum_required()
to match it.

CMakeLists.txt

index 6649281..4092f21 100644 (file)
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8.9)
+cmake_minimum_required(VERSION 2.8.11)
 
 project(liblxqt)
 
@@ -290,8 +290,10 @@ add_library(${LXQT_LIBRARY_NAME}
 
 )
 
-qt5_use_modules(${LXQT_LIBRARY_NAME} Widgets DBus X11Extras)
 target_link_libraries(${LXQT_LIBRARY_NAME}
+    Qt5::Widgets
+    Qt5::DBus
+    Qt5::X11Extras
     ${QTXDG_LIBRARIES}
 )