Adding debian version 3.5.0-4.
[debian/openbox.git] / debian / NEWS.Debian
1 openbox (3.5.0-1) unstable; urgency=low
2
3   Be aware of the following changes when upgrading to openbox 3.5
4   or later:
5
6     - There is a new config file called environment that you should 
7       copy from /etc/xdg/openbox to ~/.config/openbox
8     - The config file previously called autostart.sh is now just called
9       autostart. You should rename yours to remove the .sh from the end
10       of the name.
11     - Some of the configuration grammar in rc.xml has changed. While Openbox
12       appears to understand the old options, it would be wise to compare
13       your configuration to the one in /etc/xdg/openbox and look for changes
14       that affect you. 
15
16  -- Nico Golde <nion@debian.org>  Sun, 31 Oct 2011 23:41:20 +0200
17
18 openbox (3.4.2-1) unstable; urgency=low
19
20   - The 3.4.x release introduced quite a few changes and improvements
21     for users. Make sure to read:
22     http://icculus.org/openbox/index.php/Help:Upgrading_to_3.4
23     to take advantage of them.
24
25  -- Nico Golde <nion@debian.org>  Sun, 15 Jul 2007 23:17:28 +0200
26
27 openbox (3.0-1) unstable; urgency=low
28
29   - Openbox 3 is rewritten from scratch in C, and is now licenced under the
30     GNU General Public Licence.  Prior versions of Openbox was written in
31     C++, and based on Blackbox 0.65.0 codebase.
32     
33     The format for configuration files, menu files, and theme files has
34     been changed, so if you're upgrading from Openbox 2, you will have to
35     convert your existing setup to the new formats.  The included script
36     /usr/share/openbox/themeupdate.py may be helpful when converting themes,
37     while configuration and menu files must be done manually.
38
39     You might want to postpone upgrading this package (or downgrade it
40     if you already have), if you do not want to do the conversion now.
41
42  -- Tore Anderson <tore@debian.org>  Tue, 18 Nov 2003 19:46:48 +0100