Adding debian version 0.5.8-1.1. debian/0.5.8-1.1
authorDaniel Baumann <daniel@debian.org>
Fri, 20 Apr 2012 11:52:23 +0000 (13:52 +0200)
committerDaniel Baumann <daniel@debian.org>
Fri, 20 Apr 2012 11:52:23 +0000 (13:52 +0200)
debian/changelog
debian/control
debian/rules

index cbb7be2..57c2a6c 100644 (file)
@@ -1,3 +1,11 @@
+lxpanel (0.5.8-1.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Use dh-autoreconf to run autoreconf and intltoolize before
+    configure. (Closes: #658001)
+
+ -- S├ębastien Villemot <sebastien.villemot@ens.fr>  Sat, 18 Feb 2012 17:19:17 +0100
+
 lxpanel (0.5.8-1) unstable; urgency=low
 
   * Merging upstream version 0.5.8:
index 14b75f1..99ea23e 100644 (file)
@@ -7,7 +7,8 @@ Build-Depends:
  debhelper (>= 8), autotools-dev, docbook-xml, docbook-xsl, intltool,
  intltool-debian, libasound2-dev, libglib2.0-dev (>=2.10),
  libgtk2.0-dev (>=2.6), libiw-dev [linux-any],
- libmenu-cache1-dev (>=0.3.2), libxpm-dev, python, xsltproc
+ libmenu-cache1-dev (>=0.3.2), libxpm-dev, python, xsltproc,
+ dh-autoreconf, autopoint
 Standards-Version: 3.9.2
 Homepage: http://lxde.org
 Vcs-Git: git://git.debian.org/git/pkg-lxde/lxpanel.git
index dfc8553..26c136f 100755 (executable)
@@ -5,7 +5,14 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@
+       dh $@ --with autoreconf
+
+autoreconf:
+       autoreconf --install --force
+       intltoolize --copy --force --automake
+
+override_dh_autoreconf:
+       dh_autoreconf debian/rules -- autoreconf
 
 override_dh_auto_configure:
        dh_auto_configure -- --enable-man