Adding debian version 0.4.1+svn20090524-2. debian/0.4.1+svn20090524-2
authorDaniel Baumann <daniel@debian.org>
Fri, 20 Apr 2012 11:46:21 +0000 (13:46 +0200)
committerDaniel Baumann <daniel@debian.org>
Fri, 20 Apr 2012 11:46:21 +0000 (13:46 +0200)
debian/changelog
debian/control
debian/rules

index df38dec..2cc64de 100644 (file)
@@ -1,3 +1,14 @@
+lxpanel (0.4.1+svn20090524-2) unstable; urgency=low
+
+  * Update debian/control (Thanks Jonas Smedegaard's for the advice):
+    - Move conflicts lxnm ( <0.3 ) from lxpanel-netstat-plugin to lxpanel
+    - Make lxpanel-netstat-plugin dummy package depends on connman
+      (See ITP #475022 for detail)
+  * Removed deprecated dh_desktop from debian/rules
+  * Bumped Standard-version to 3.8.2
+
+ -- Andrew Lee <andrew@linux.org.tw>  Sun, 19 Jul 2009 13:48:27 +0200
+
 lxpanel (0.4.1+svn20090524-1) unstable; urgency=low
 
   * New upstream release (Closes: #516603, #511001, #493242, #486284, 
index 8deaf31..9e555d2 100644 (file)
@@ -3,7 +3,7 @@ Section: x11
 Priority: optional
 Maintainer: Andrew Lee <andrew@linux.org.tw>
 Build-Depends: debhelper (>= 5), autotools-dev, intltool, libgtk2.0-dev (>=2.6), libglib2.0-dev (>=2.10), libxmu-dev, libxpm-dev, libiw-dev, libasound2-dev, libmenu-cache-dev (>=0.2.5), docbook-to-man, dpatch, python
-Standards-Version: 3.8.1
+Standards-Version: 3.8.2
 DM-Upload-Allowed: yes
 Homepage: http://www.gnomefiles.org/app.php/LXPanel
 
@@ -11,6 +11,7 @@ Package: lxpanel
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}, lxmenu-data
 Suggests: lxsession-lite (>=0.3.5) | lxsession (>=0.3.2) | menu, lxpanel-netstat-plugin, www-browser
+Conflicts: lxnm ( <0.3 )
 Description: a lightweight desktop panel for X
  LXPanel is a lightweight GTK+2 desktop panel derived from fbpanel. Its
  features include:
@@ -32,9 +33,7 @@ Description: a lightweight desktop panel for X
 
 Package: lxpanel-netstat-plugin
 Architecture: all
-Depends: ${misc:Depends}, lxpanel (>= ${binary:Version}), wicd | network-manager-gnome 
-Conflicts: lxnm (< 0.3)
-Replaces: lxnm
+Depends: ${misc:Depends}, lxpanel (>= ${binary:Version}), wicd | network-manager-gnome | connman 
 Description: transiational dummy package which can be safely removed
  Due to upstream dropped netstat plugin. User who installed old 
  lxpanel-netstat-plugin are encouraged to switch to either wicd or 
index 6093eb2..a2e0627 100755 (executable)
@@ -126,7 +126,6 @@ binary-arch: build install
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
-       dh_desktop -A lxde-x-terminal-emulator.desktop lxde-x-www-browser.desktop
        dh_installman
        dh_link
        dh_strip