Removing obsolete target override_dh_builddeb from debian/rules file.
[debian/lxpanel.git] / debian / rules
CommitLineData
6f31b6c9 1#!/usr/bin/make -f
6f31b6c9 2
36dc3f6c 3DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ceae02d0 4
be3ccd97 5export DEB_BUILD_MAINT_OPTIONS = hardening=+all
807a1985 6
7ae3952f 7%:
011cf3fe
AG
8 dh ${@} --parallel --with autoreconf
9
10override_dh_autoreconf:
11 dh_autoreconf ./autogen.sh --
6f31b6c9 12
7ae3952f 13override_dh_auto_configure:
5f1d39cc 14ifeq ($(DEB_HOST_ARCH_OS),linux)
a57249b5 15 dh_auto_configure -- --enable-man --with-plugins=all --disable-silent-rules
5f1d39cc 16else
ceae02d0 17 # omit netstat plugin on non-linux, requires wireless-tools
5f3a7045 18 dh_auto_configure -- --enable-man --with-plugins=all,-netstat --disable-silent-rules
ceae02d0 19endif
6f31b6c9 20
0d509f4d
DB
21override_dh_strip:
22 dh_strip --dbg-package=lxpanel-dbg
baafee54
AG
23
24override_dh_makeshlibs:
25 # plugins are not shared libs so disable processing for them
26 dh_makeshlibs -X/plugins/